トップページ | 過去記事(月別カテゴリー別) | 掲示板 | 野良DEB,RPM | 更新チェック | Twitter
<<  2011.4  >>
SMTWTFS
     12
3456789
10111213141516
17181920212223
24252627282930
 
リンク
その他
  • RSS2.0
  • Credit

  • SEO
    loading

    プライバシーポリシー
    Google

カテゴリー » Linux » Ubuntu April 29, 2011

Ubuntu 11.04(Natty Narwhal)用の野良リポジトリを作成 Ubuntu

自分が欲しいと思ったアプリのDebパッケージを少し置いてますリポジトリにあるアプリの説明
  • Anthy(Modified Anthy)
    パッケージ取得のリポジトリを有効にすると、Ubuntu標準の日本語入力システム「Anthy」が「Modified Anthy」に変化します。勝手に変えるなバカヤローという人は、リポジトリを使わない方がいいです
  • Mozc
    最近注目の日本語入力システムです。常に最新バージョンを追いかけるつもり。

    Ubuntu標準リポジトリの「emacs-mozc_1.0.558.102-1」はミスがあって、インストールするとEmacsの設定が吹っ飛びます(吹っ飛ぶという言葉は言い過ぎでした)

    元となったDebianの方は一ヶ月以上前に修正されているのに、Ubuntuはそのまま。

    下の JD もそうだけど、こういうのって修正されないの? と疑問に思って調べてみると、
    >unvierseコンポーネント
    >Canonicalはunvierseコンポーネントのソフトウェアに対して恒常的なセキュリティアップデートを保証していませんが、コミュニティの手によるセキュリティアップデートが提供される可能性はあります。

    >multiverseコンポーネント
    >multiverseに属するソフトウェアはサポートされません。また、おそらく修正されることも、アップデートされることもないでしょう。各自の責任で利用してください。

    コンポーネント | Ubuntu Japanese Team
    Mozcは「multiverse」、jdは「universe」に属しているので、あまりアップデートを期待できないわけですな。
  • UMPlayer
    SMPlayerから派生した動画プレイヤーです
    コーデック内蔵でYouTube動画やDVDの再生もできる動画プレイヤー: ubuntuApps
    (この紹介ではメニュー等が英語ですが、最新版は日本語化されています)

    《注意》
    4月30日以前にインストールした人は一度再インストールしてください。バージョン番号の関係で今後のアップデートに支障が出るかもしれません(下のコメントを参照)
  • SRWare Iron
    Chromium派生のWebブラウザです
  • JD for Linux
    2ちゃんねるブラウザです。--with-migemo付きでビルドしています。Ubuntuが用意しているJDは、バージョンが古くて忍法帖に未対応・書き込みできません
  • libjpeg-turbo
    インストールするとJPEG画像の読み込み・変換などが高速化されます
  • ONScripter
    NScripterで作られたゲームを動かすプログラムです。コマンドで動かすのが面倒なので、NScripterのファイル(*.sar,*.nsa)に関連付けする設定を加えてあります
  • gdk-pixbuf-psdXcf Pixbuf Loader
    PhotoshopとGIMPの画像ファイルを読み込めるようにするライブラリ
  • cpulimit
    プロセスのCPU使用率を制限するコマンドです
  • extundelete
    削除したファイルを復元するコマンドです
  • lha-sjis
    Ubuntu Japanese Team提供のだと上手く解凍できない時がある
そういえば、今回もデフォルトだと日本語入力の言語パネルが表示されませんねそのままだと単語登録・ユーザ辞書の編集がやりにくくて困ります。
Fedoraの場合、というかUbuntu以外は非表示でもIBusのアイコンクリックから単語登録できるんだけどなー
03:17 pm | コメントする |

上の記事に対するコメント

1. masahiro  2011/04/29 20:11
11。04への早速の対応、ありがとうございます。

2. Owner CommentSawa  2011/04/29 22:33
実はまだlibjpeg-turbo以外の動作確認を行ってなかったりして。
たぶん大丈夫。

Mozcだけが欲しいなら、Japanese Termの中の人のリポジトリを使うのも手ですね
http://blog.goo.ne.jp/ikunya/e/b15cbce88641c4af144ad8c871a898db

3. Owner CommentSawa  2011/04/30 00:08
一通りちゃんとインストールして使えることを確認。
うん、大丈夫だった。

4. aozora_genei (Website)  2011/04/30 08:48
umplayerのバージョン、PPA上では1.0.0ですが、本体上では0.9.5と表示されています。

5. shin  2011/04/30 12:17
そういえば、これ
> gdk-pixbuf-psd、Xcf Pixbuf Loader
> PhotoshopとGIMPの画像ファイルを読み込めるようにするライブラリ
は、10.04には含まれていないようですが、なにか技術上の問題があるのでしょうか?

6. Owner CommentSawa  2011/04/30 13:51
>aozora_geneiさん
作者さんの debian/changelog では1.0になっています。
http://umplayer.svn.sourceforge.net/viewvc/umplayer/umplayer/trunk/debian/changelog?revision=110
でも、よく読むとこれ変ですね。下の日付が2009年になってます。
ver-0.92が今年四月リリースなのに、ver-1.0が2009年、うむむむむ…
どうしようかな、、、とりあえずPPAにファイルを削除するリクエストを出しておきます(実際に消えるまで少し時間が掛かる)

>shinさん
そのままだと動かないのでアップロードしていません。
10.10以降とファイルの置き場所が違うだけなのですが、放置しています(^^;

7. aozora_genei (Website)  2011/04/30 20:49
そちらのはdebianパッケージ版のrev110でしたか。
最新がrev152のようですが、特に問題はないので今後はWebUpd8様のPPAのrev143を使用することにします。

8. Owner CommentSawa  2011/04/30 22:16
debianパッケージ版、という言葉の意味が分からないのですが、とにかく中身は最新版です。

作ったばかりで使っている人は少ないだろうし、バージョン番号を下げてビルドしなおしてます(現在PPAのビルド待ち)

9. NONAME  2011/05/13 14:36
mintでも使えるでしょうか?

10. Owner CommentSawa  2011/05/14 00:20
http://ja.wikipedia.org/wiki/Linux_Mint のことですよね?
説明文を見る限り、十中八九使えると思います。

11. bunbukubuku (Website)  2011/06/15 14:32
ありがとうございます。extundelete助かりました。

コメントをどうぞ。名前とURLはオプションです。

Comment Form
NAME:
URL:
文字色:  

累計:1621080、今日:355、昨日:2015
Created in 0.0108 sec.